phpmyadmin ubuntu 16.04

$ sudo apt-get update

$ sudo apt-get install phpmyadmin php-mbstring php-gettext

$ sudo phpenmod mcrypt

$ sudo phpenmod mbstring

$ sudo systemctl restart apache2

phpMyAdminを保護する

$ vi /etc/apache2/conf-available/phpmyadmin.conf

<Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php
    AllowOverride All
    . . .

$ sudo systemctl restart apache2
$ vi /usr/share/phpmyadmin/.htaccess
AuthType Basic
AuthName "Restricted Files"
AuthUserFile /etc/phpmyadmin/.htpasswd
Require valid-user

$ sudo htpasswd -c /etc/phpmyadmin/.htpasswd username


関連広告記事

シェアする

  • このエントリーをはてなブックマークに追加

フォローする