サーラリマンは働き過ぎ、社畜化に注意しよう!!

Asterisk oplus

asterisk

opusを使えるようにするには苦労した。

使えるバージョンが限られている。

wget https://raw.githubusercontent.com/netaskd/asterisk-opus/master/asterisk-11.5.0_opus+vp8.diff

asterisk-11.5.0_opus+vp8.diff このパッチだけがうまくいった。

このパッチにが使えるバージョンは asterisk11.5 ~ asterisk11.9

cd /usr/local/src

wget http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-11.9.0.tar.gz

tar zxvf asterisk-11.9.0.tar.gz

cd asterisk-11.9.0

wget https://raw.githubusercontent.com/netaskd/asterisk-opus/master/asterisk-11.5.0_opus+vp8.diff

patch -p1 -u < asterisk-11.5.0_opus+vp8.diff

./bootstrap.sh

./configure

make menuselect

make

make install

コメント